¿Qué versión de Dokka va con qué versión de Kotlin?

Cada vez que las versiones de Kotlin y Dokka no son compatibles, las cosas pueden romperse de manera extraña en las comstackciones de Gradle y Maven. No puedo encontrar en ninguna parte una list de las versiones compatibles entre los dos. ¿Cuál es la compatibilidad de versión?

Nota: esta pregunta fue escrita y respondida intencionalmente por el autor ( Preguntas de respuesta automática ), de modo que las respuestas idiomáticas a los temas de Kotlin comúnmente formulados están presentes en SO.

Aquí están las versiones compatibles que coinciden:

 Versión de Kotlin Dokka Version
 ---------------- | -----------------
 1.0.0 0.9.7
 1.0.1 0.9.7
 todo 0.9.8 o posterior 

Desde 0.9.8 Dokka ya no puede entrar en conflicto con las classs del comstackdor, ya que incorpora una versión sombreada del comstackdor.

Ver las versiones actuales en el repository de maven