Articles of android studio

Diferencia entre protegido y sin

Hola a todos, tengo este código en Kotlin para Android, pero no sé por qué no funciona. Aquí está mi código: package com.test.tictac import android.support.v7.app.AppCompatActivity import android.os.Bundle import android.view.View import android.widget.Button import android.widget.Toast class MainActivity : AppCompatActivity() { override fun onCreate(savedInstanceState: Bundle?) { super.onCreate(savedInstanceState) setContentView(R.layout.activity_main) } protected fun buClick(view: View) { val buSelected = view […]

¿KAnnotator está trabajando en Android Studio?

He instalado KAnnotator (0.2.1205) en Android Studio (0.5.8). Se generaron las annotations, pero me parece que no se usan, o no lo entiendo. Hay una anotación: <item name='android.support.v4.app.NotificationCompat.Builder android.support.v4.app.NotificationCompat.Builder setContentTitle(java.lang.CharSequence)'> <annotation name='org.jetbrains.annotations.NotNull'/> </item> Pero aún así, tengo que escribir: NotificationCompat.Builder(context) .setContentTitle(myTitle)!! ¿Debo adjuntar manualmente las annotations? ¿Si es así, donde?

Error de compilation de Android 3.0 Canary: Versión major.minor no compatible 52.0

Actualización: Lo resolví siguiendo el consejo de https://stackoverflow.com/a/37712635/288724 Este enlace no proporcionaba una buena solución para Android Studio Unsupported major.minor versión 52.0 Pero este enlace https://stackoverflow.com/a/37712635/288724 me ayudó. Vi que muchas personas conocieron el problema similar antes. Sin embargo, mi Android Studio 2.3.2 funciona totalmente bien, el problema solo se muestra cuando estoy usando Android […]

Error: Error al convertir bytecode a dex: Causa: método de interfaz pnetworkingeterminado o estático utilizado sin –min-sdk-version> = 24

Aquí está el sorteo de mi demo: compile fileTree(include: ['*.jar'], dir: 'libs') androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'org.jetbrains.kotlin:kotlin-android-extensions:1.1.2' compile 'com.android.support.constraint:constraint-layout:1.0.2' compile 'com.android.support:appcompat-v7:25.3.1' Yo uso Android-Studio 3.0, y aquí están los detalles del error .

Referencia no resuelta en Android Studio 3 Canary

Intento usar Carto Mobile SDK, pero Android Studio me sigue diciendo Unresolved reference: com.carto.ui.MapView . Tengo el último Android Studio Canary, he actualizado los complementos de gradle y kotlin y todavía no funciona. Esto solo ocurre en Android Studio 3.0 Canary, funciona en Android Studio 2.3.3. Estos son mis files gradle: Proyecto gradle: buildscript { […]

La construcción gradle de Android falla repentinamente en ': app: mergeDebugResources' sin posts de error

Mi construcción gradle dejó de funcionar completamente de la nada. Minuto antes funcionó bien. No cambió nada en los files de configuration de Gradle; de hecho, solo estaba cambiando el estilo de la aplicación en XML. Haga, limpie y ejecute producir: Execution failed for task ':app:mergeDebugResources'. > -1 Ejecutando gradle con –stacktrace produce: Executing task […]

Error de generación: Error: ejecución fallida para la tarea ': aplicación: compileLightningLiteDebugKotlin'. > Error de compilation

Solo estaba jugando con el browser Lightening y refactorizado el nombre del package, me pregunto cómo me vino el error, antes pensaba que podría tener algunas dependencies de versión. Amablemente ayúdame a resolver este problema. Lo que me hizo tener este problema, había resuelto este problema antes, pero accidentalmente. Entonces, amablemente ayúdenme a hacer un […]

La ejecución de Android falló para la tarea app.compileDebugKotlin cuando se usa firebase

Obteniendo este error Error:Execution failed for task ':app:compileDebugKotlin'. > Comstacktion error. See log for more details Tan pronto como agregue esta línea de código a la aplicación firebaseAuth = FirebaseAuth.getInstance() Dependency se agrega al module de aplicación gradle compile 'com.google.firebase:firebase-auth:10.0.1' ¿Alguna idea de lo que está causando este error? EDITAR : Supertypes of the following […]

Por qué el complemento de Kotlin agrega reference de kotlin-stdlib-jre7 (no kotlin-stdlib) para el proyecto de Android

Android Studio 2.3.3; Complemento de Kotlin: 1.1.4; Comstackdor Kotlin: Kotlin a JVM: 1.6. Android Studio> Nuevo proyecto> Configurar Kotlin en la acción Proyecto agrega reference para kotlin-stdlib-jre7 al file gradle. Esperaría kotlin-stdlib ya que Kotlin target JVM es 1.6. No he encontrado una buena explicación. Por ejemplo, esta respuesta dice que Se supone que el […]

Android Studio falla refactorizando el código generado de kapt "de solo lectura"

Trabajando con Kotlin y Dagger encuentro que si trato de usar la function Refactoring de Android Studio para cambiar, por ejemplo, el nombre de una class a la que se hace reference en el código que kapt autogenera para Dagger (en $ buildDir / generated / source / kapt), que el refactorizador falla porque el […]