IntelliJ importa Java Boolean y luego arroja un error

(En primer lugar, sí, desarrollo de complementos Minecraft. Vive con él)

Por lo tanto, estoy desarrollando Kotlin en IntelliJ IDEA Ultimate, pero realmente me odia cuando se trata de importar java.lang.Boolean lugar de kotlin.Boolean automágicamente.

El complemento My Kotlin está completamente actualizado, al igual que IntelliJ según JB Toolbox.

Cada vez que presiono CTRL+ALT+L para auto-formatear e importar automáticamente, importa java.lang.Boolean y luego arroja errores en el file que debería usar kotlin.Boolean . De hecho, es tan simple como eliminar la import, pero eso es un esfuerzo extra para nada, ya que debería ser capaz de hacer esto por sí mismo. Puede tener algo que ver con la extensión de una class Java, que tiene methods que devuelven un Booleano Java, pero no veo cómo sería este el caso, ya que es simplemente demasiado molesto y más usuarios deberían haberlo notado antes.

Si cambio el tipo de devolución a java.lang.Boolean dice que la class invalidada, sin connection alguna con Kotlin STD-Lib, usa la versión de Kotlin y que debería cambiarla a kotlin.Boolean . Esto me ha molestado hace un time, ¿alguien tiene alguna idea?

El file en cuestión es, por cierto, esto: https://gitlab.com/proximyst/HellishSurvival/blob/master/Plugin/src/main/java/com/proximyst/hellishsurvival/Commands.kt