IntelliJ Idea cuando se testingn múltiples modules a la vez, solo se incluyen artefactos de un module

Tengo un proyecto que utiliza Maven con 3 modules: uno principal, central y complemento. Core tiene los mismos artefactos que parent, pero addon tiene uno adicional. Cuando realizo testings para el complemento, todo funciona bien. El problema ocurre cuando pruebo ambos modules a la vez. Las testings actúan como si el module adicional no tuviese ese artefacto adicional que hace que las testings fallen. De nuevo, esto solo ocurre cuando pruebo ambos modules a la vez. A continuación puede encontrar mi configuration.

config

Parent pom:

<?xml version="1.0" encoding="UTF-8"?> <project xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://maven.apache.org/POM/4.0.0" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <modelVersion>4.0.0</modelVersion> <groupId>com.github.mibac138.argparser</groupId> <artifactId>parent</artifactId> <packaging>pom</packaging> <version>1.0-SNAPSHOT</version> <modules> <module>Binder</module> <module>Core</module> </modules> <properties> <java.source>1.6</java.source> <java.target>1.6</java.target> <kotlin.version>1.1.2</kotlin.version> </properties> <pluginRepositories> <pluginRepository> <id>jcenter</id> <name>JCenter</name> <url>https://jcenter.bintray.com/</url> </pluginRepository> </pluginRepositories> <licenses> <license> <name>MIT License</name> <url>http://www.opensource.org/licenses/mit-license.php</url> </license> </licenses> <dependencies> <dependency> <groupId>org.jetbrains.kotlin</groupId> <artifactId>kotlin-stdlib</artifactId> <version>${kotlin.version}</version> </dependency> <dependency> <groupId>org.jetbrains.kotlin</groupId> <artifactId>kotlin-runtime</artifactId> <version>${kotlin.version}</version> </dependency> <dependency> <groupId>junit</groupId> <artifactId>junit</artifactId> <version>4.12</version> <scope>test</scope> </dependency> <dependency> <groupId>org.testifyproject.mock</groupId> <artifactId>mockito</artifactId> <version>0.9.2</version> <scope>test</scope> </dependency> <dependency> <groupId>com.nhaarman</groupId> <artifactId>mockito-kotlin</artifactId> <version>1.4.0</version> <scope>test</scope> </dependency> <dependency> <groupId>org.jetbrains.kotlin</groupId> <artifactId>kotlin-test-junit</artifactId> <version>${kotlin.version}</version> <scope>test</scope> </dependency> </dependencies> <build> <plugins> <plugin> <groupId>org.jacoco</groupId> <artifactId>jacoco-maven-plugin</artifactId> <version>0.7.9</version> <executions> <execution> <goals> <goal>prepare-agent</goal> </goals> </execution> <execution> <id>report</id> <phase>test</phase> <goals> <goal>report</goal> </goals> </execution> </executions> </plugin> <plugin> <groupId>org.jetbrains.dokka</groupId> <artifactId>dokka-maven-plugin</artifactId> <version>0.9.13</version> <executions> <execution> <id>attach-kotlindocs</id> <phase>pre-site</phase> <goals> <goal>javadoc</goal> </goals> </execution> </executions> </plugin> <plugin> <groupId>org.jetbrains.kotlin</groupId> <artifactId>kotlin-maven-plugin</artifactId> <version>${kotlin.version}</version> <executions> <execution> <id>compile</id> <phase>compile</phase> <goals> <goal>compile</goal> </goals> </execution> <execution> <id>test-compile</id> <phase>test-compile</phase> <goals> <goal>test-compile</goal> </goals> </execution> </executions> </plugin> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <version>3.6.1</version> <configuration> <source>${java.source}</source> <target>${java.source}</target> </configuration> <executions> <execution> <id>compile</id> <phase>compile</phase> <goals> <goal>compile</goal> </goals> </execution> <execution> <id>testCompile</id> <phase>test-compile</phase> <goals> <goal>testCompile</goal> </goals> </execution> <execution> <id>default-compile</id> <phase>none</phase> </execution> <execution> <id>default-testCompile</id> <phase>none</phase> </execution> </executions> </plugin> </plugins> </build> </project> 

Core pom:

 <?xml version="1.0" encoding="UTF-8"?> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <parent> <artifactId>parent</artifactId> <groupId>com.github.mibac138.argparser</groupId> <version>1.0-SNAPSHOT</version> </parent> <modelVersion>4.0.0</modelVersion> <artifactId>argparser-core</artifactId> </project> 

Addon pom:

 <?xml version="1.0" encoding="UTF-8"?> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <parent> <artifactId>parent</artifactId> <groupId>com.github.mibac138.argparser</groupId> <version>1.0-SNAPSHOT</version> </parent> <modelVersion>4.0.0</modelVersion> <artifactId>argparser-binder</artifactId> <dependencies> <dependency> <groupId>io.github.mibac138.argparser</groupId> <artifactId>argparser-core</artifactId> <version>1.0-SNAPSHOT</version> </dependency> <dependency> <groupId>org.jetbrains.kotlin</groupId> <artifactId>kotlin-reflect</artifactId> <version>1.1.2</version> </dependency> </dependencies> </project> 

Específicamente, los kotlin-reflect es que no estaba allí cuando se ejecutaban testings en todo el proyecto.