Groovy no puede resolver classs de kotlin

Como no pude resolver el problema que tengo con kotlin , decidí volver a groovy para implementar el complemento.

Sin embargo, me encontré con el problema. Tengo tal estructura de proyecto.

enter image description here

Para no reescribir todas las classs, decidí reutilizar las classs implementadas en kotlin .

Sin embargo, mis classs FileProcessingCoreGroovy y DownloadCoreGroovy no pueden resolver la class ProcessStream y UnpackStream .

Pensé que deberían poder usar libremente el uno al otro, pero creo que estaba equivocado. ¿Cuál es el problema?

Las classs en sí mismas son importadas perfectamente por IDE (no marcadas en color rojo, etc.)

enter image description here

La salida de la console se ve así (utilizo otra class donde importo PluginUtils de kotlin classs de kotlin )

 :clean :compileKotlin (...multiple deprecated messages...) :compileJava UP-TO-DATE :compileGroovy startup failed: D:\groovy_apps\MISC\gradle-app-environment-plugin\src\main\groovy\com.lapots.gradle.plugins.appenv\ApplicationEnvironmentGroovyPlugin.g roovy: 4: unable to resolve class com.lapots.gradle.plugins.appenv.core.PluginUtils @ line 4, column 1. import com.lapots.gradle.plugins.appenv.core.PluginUtils ^