gradle build para el código de kotlin

Estoy tratando de configurar un proyecto que construya el código de Kotlin con Gradle. He seguido las instrucciones aquí sobre cómo configurar el file build.gradle pero recibo un error

buildscript { repositories { mavenCentral() jcenter() } dependencies { classpath 'org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.0' } } apply plugin: 'kotlin' 

Con esto obtengo el error:

FALLO: la compilation falló con una exception.

  • Qué salió mal: se produjo un problema al configurar el proyecto raíz 'kjsonparser'. No se pudieron resolver todos los files para la configuration ': classpath'. No se pudo resolver org.jetbrains.kotlin: kotlin-gradle-plugin: 1.2.0. Requerido por: proyecto: no se pudo resolver org.jetbrains.kotlin: kotlin-gradle-plugin: 1.2.0. No se pudo get el recurso ' https://repo.maven.apache.org/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0/kotlin-gradle-plugin-1.2.0.pom '. No se pudo OBTENER ' https://repo.maven.apache.org/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.0/kotlin-gradle-plugin-1.2.0.pom '. java.lang.RuntimeException: error inesperado: java.security.InvalidAlgorithmParameterException: el parámetro trustAnchors debe estar no vacío

También probé la forma "más nueva" de especificar el complemento

 plugins { id "org.jetbrains.kotlin.jvm" version "1.2.0" } 

Lo que da este error:

  • Qué salió mal: el complemento [id: 'org.jetbrains.kotlin.jvm', versión: '1.2.0'] no se encontró en ninguna de las siguientes fonts:

Complementos básicos de Gradle (el complemento no está en el espacio de nombres 'org.gradle') – Repositorios de complementos (no se pudo resolver el artefacto del complemento> 'org.jetbrains.kotlin.jvm: org.jetbrains.kotlin.jvm.gradle.plugin: 1.2.0' ) Búsqueda en los siguientes repositorys: Gradle Central Plugin Repository

Versión de Gradle

 gradle -version ------------------------------------------------------------ Gradle 4.4 

Kotlin (y openjdk) kotlin -version Kotlin versión 1.2.0 (JRE 1.8.0_151-8u151-b12-0ubuntu0.17.10.2-b12)

Funcionando en Ubuntu 17.10

Nunca he trabajado con Gradle antes, así que no estoy seguro de si me falta algo en el file de compilation