¿Existe una convención de nomenclatura recomendada para los files que solo contienen funciones / methods de extensión?

En Java, es simple: el nombre de file para un tipo es el nombre de un tipo más el sufijo .java .

En Kotlin, puede escribir files que no contienen classs. ¿Hay alguna convención para nombrarlos?

¿Y también cómo nombrarías las classs de testing unitarias para esas funciones?

StringExt.kt para el file con funciones de extensión de String .

CollectionExt.kt para las funciones de extensión de collections.