¿Es posible ejecutar la última versión de Akka Framework (2.5.2) en un proyecto de Android?

Estoy desarrollando un proyecto de Android y me pregunto si es posible usar Akka framework v. 2.5.2. Este marco necesita Java 8 para ejecutarse y sé que Android no es compatible con Java 8. ¿Hay alguna configuration que lo haga funcionar? Tal vez usando Kotlin?