Error de Kotlin: no se pudo encontrar org.jetbrains.kotlin: kotlin-stdlib-jre7: 1.0.7

Instalé el complemento de Kotlin en mi aplicación (v. V.1.1.1-release-Studio2.2-1) y luego seleccioné "Configurar Kotlin en el proyecto" Seleccioné el comstackdor y la versión de time de ejecución de 1.0.7. Kotlin actualizó mis files Gradle. Ahora cuando trato de build, obtengo:

Error: se produjo un problema al configurar el proyecto ': aplicación'. No se pudieron resolver todas las dependencies para la configuration ': app: _debugApkCopy'. No se pudo encontrar org.jetbrains.kotlin: kotlin-stdlib-jre7: 1.0.7. Requerido por:

MyApplication: aplicación: no especificada

No estoy seguro de lo que me falta aquí.

Solutions Collecting From Web of "Error de Kotlin: no se pudo encontrar org.jetbrains.kotlin: kotlin-stdlib-jre7: 1.0.7"

En el nivel de Proyecto, use solo esta versión

ext.kotlin_version = '1.1.1'

Eliminar otra versión

La split de kotlin-stdlib en kotlin-stdlib-jre7 y kotlin-stdlib-jre8 solo se introdujo con Kotlin 1.1, por eso la dependencia no se puede resolver, la versión del package simplemente no existe.

Parece que la actualización de los files de su proyecto falló en algún momento y configuró la versión de Kotlin en 1.0.7. Si se trata de un proyecto nuevo y no hay nada que te impida utilizar 1.1.1, cambiaría a eso. Tu problema debería desaparecer después de hacer esto.

En el file "build.gradle", cambie la versión actual de Kotlin de esa línea y presione synk:

 ext.kotlin_version = '1.1.1' 

/// Eso se verá así:

// Archivo de compilation de nivel superior donde puede agregar opciones de configuration comunes a todos los subproyectos / modules.

 buildscript { ext.kotlin_version = '1.1.1' repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.3.0' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 
  1. Por favor revise la versión actual de su Kotlin en la ruta siguiente,

    C: \ Archivos de progtwig \ Android \ Android Studio \ gradle \ m2repository \ org \ jetbrains \ kotlin \ kotlin-stdlib \ 1.0.5

cambie a esa versión (1.0.5) en el file gradle de nivel de proyecto.

Usted puede ver que en su ruta anterior no menciona ninguna jre version Java- jre version , por lo tanto, elimine en su file gradle de nivel de aplicación como se muestra a continuación,

 compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version" 

https://stackoverflow.com/a/44148210/8056898

Cambia la versión de Kotlin según tu versión actual en el sistema.