Error de compilation de Android 3.0 Canary: Versión major.minor no compatible 52.0

Actualización: Lo resolví siguiendo el consejo de https://stackoverflow.com/a/37712635/288724

Este enlace no proporcionaba una buena solución para Android Studio Unsupported major.minor versión 52.0

Pero este enlace https://stackoverflow.com/a/37712635/288724 me ayudó.

Vi que muchas personas conocieron el problema similar antes. Sin embargo, mi Android Studio 2.3.2 funciona totalmente bien, el problema solo se muestra cuando estoy usando Android Studio 3.0 Canary 1 con soporte de kotlin .

La información de error es la siguiente:

Error:(1, 1) A problem occurnetworking evaluating project ':app'. > java.lang.UnsupportedClassVersionError: com/android/build/gradle/AppPlugin : Unsupported major.minor version 52.0 

¿Alguien puede darme alguna sugerencia? ¡Muchas gracias!