El complemento gradle de Android se queja de un error de traducción no detectada

Estoy actualizando mi versión de kotlin a 1.0.0-beta-2423, todo lo que hice fue actualizar los numbers de versión de las dependencies relacionadas. Pero cuando ejecuto la tarea assembleDebug, se queja de este error.

:app:transformClassesWithDexForDebug Uncaught translation error: com.android.dx.cf.code.SimException: expected type java.lang.Object but found int Uncaught translation error: com.android.dx.cf.code.SimException: expected type java.lang.Object but found int 2 errors; aborting Error:Execution failed for task ':app:transformClassesWithDexForDebug'. > com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command '/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/bin/java'' finished with non-zero exit value 1 

Todas mis dependencies enumeradas aquí:

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.my.domain" minSdkVersion 18 targetSdkVersion 23 multiDexEnabled true versionCode 3 versionName "0.0.3" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } sourceSets { main.java.srcDirs += 'src/main/kotlin' } dexOptions { javaMaxHeapSize "4g" } packagingOptions { exclude 'META-INF/DEPENDENCIES' exclude 'META-INF/NOTICE' exclude 'META-INF/LICENSE' exclude 'META-INF/LICENSE.txt' exclude 'META-INF/NOTICE.txt' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile project(':hermes') compile project(':widget') testCompile 'junit:junit:4.12' compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version" compile "org.jetbrains.anko:anko-sdk23:$anko_version" compile "org.jetbrains.anko:anko-support-v4:$anko_version" apk "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version" compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.android.support:recyclerview-v7:23.1.1' compile 'com.android.support:design:23.1.1' compile 'com.android.support:support-annotations:23.1.1' compile 'com.android.support:percent:23.1.1' compile 'io.reactivex:rxkotlin:0.30.1' compile 'io.reactivex:rxandroid:1.0.1' compile 'io.reactivex:rxjava:1.0.14' compile 'io.reactivex:rxjava-math:1.0.0' compile 'com.fasterxml.jackson.module:jackson-module-kotlin:2.6.3-4' compile 'com.android.support:cardview-v7:23.1.1' compile 'com.google.android.gms:play-services-location:8.1.0' compile 'pl.charmas.android:android-reactive-location:0.8@aar' compile 'com.android.support:multidex:1.0.1' compile 'de.hdodenhof:circleimageview:1.3.0' } buildscript { ext.kotlin_version = '1.0.0-beta-2423' ext.anko_version = '0.7.3' repositories { mavenCentral() } dependencies { classpath "org.jetbrains.kotlin:kotlin-android-extensions:$kotlin_version" classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" } } repositories { mavenCentral() } 

¿Qué está mal aquí?

actualización: todo el build.gradle está udpated