¿Cómo especificar la versión de Kotlin?

Quiero comstackr mi progtwig Kotlin usando Kotlin 1.0.4 . ¿Cuáles son las opciones correctas de línea de command para este propósito? Escuché sobre la opción de -version , pero no entiendo cómo usarla. -version 1.0.4 no funciona.

El argumento de línea de command para este propósito es -language-version y su valor debe ser una versión major.minor Kotlin, de la cual solo hay dos en este momento: 1.0 y 1.1.

 kotlinc -language-version 1.0 source.kt 

Para hacer que el análisis en IntelliJ IDEA tenga en count la versión contra la que se comstackrá la fuente, puede crear una faceta (Configuración del proyecto -> Facetas -> "+") y seleccionar la versión del idioma en el menu desplegable de allí.

  • Una expresión regular que reconocería a / * ... * / note
  • Las classs Dagger se muestran en rojo, pero siguen construyendo
  • Kotlin "Cualquier tipo que implemente una interfaz"
  • Kotlin: Declaración a Lambda
  • Ejecutar service en segundo plano
  • Asigna lambda directamente al método abstracto henetworkingado
  • Kotlin con fragments
  • java.lang.IllegalStateException ¿No está seguro de que sea con el tipo de datos?
  • La versión de kotlin que se utiliza para comstackr con gradle (1.1.2-5) difiere de la que se incluye en el complemento IDE (1.1.2-4)
  • ¿Cómo asignar un nuevo valor si configura el setter como privado en kotlin?
  • Convirtiendo un Observable en un Flujo con contrapresión en RxJava2