Cómo depurar el error "No se pudo resolver com.google.android:android" en Anko

compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" //Anko compile "org.jetbrains.anko:anko:$anko_version" compile "org.jetbrains.anko:anko-coroutines:$anko_version" compile "org.jetbrains.anko:anko-appcompat-v7:$anko_version" compile 'org.jetbrains.kotlinx:kotlinx-coroutines-android:0.13' Build error: Error:Failed to resolve: Could not resolve com.google.android:android:2.3.1. Requinetworking by: project :app > org.jetbrains.kotlinx:kotlinx-coroutines-android:0.13 

Tengo el mismo error cuando instalé Android Studio 2.4 Preview. Solo asegúrate de que tu build.gradle a nivel de proyecto se vea así

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { ext.kotlin_version = '1.1.2-3' repositories { jcenter() mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.3.1' //Version must be exactly 2.3.1 classpath 'com.google.gms:google-services:3.0.0' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" } } 

Eliminar la linea

 compile "org.jetbrains.anko:anko-coroutines:$anko_version" 

e inténtalo de nuevo, por favor. O pegue el build.gradle completo.

  • Kotlin + Spring Boot solicita sorting
  • Devuelve valor para una variable que aparentemente puede ser nula pero realmente no puede
  • Cómo emular el mismo comportamiento en kotlin
  • ¿Qué significa este error cuando se convierte del código java a genérico en kotlin, prohibición única después de T?
  • Anotaciones de Android con Kotlin y herramientas de compilation 2.3.0
  • No se puede usar la validation de spring con MongoDB
  • Extensiones y variables de Kotlin para Android
  • convert comparator en lambda en Kotlin
  • Kotlin - Mockito no puede burlarse / espiar (Spring REST API)
  • La conversión de unidades de kilómetros a millas no devuelve el resultado esperado
  • Broadcast Receiver en la class de aplicación android