android-kotlin error: databinding de reference no resuelto & ActivityMainBinding

Estoy usando la versión de Android Studio 3.0 Canary 6. He habilitado el data binding en mi class y el código no muestra ningún error. Pero cuando construyo un APK, la construcción falla y muestra el siguiente error:

Error:(8, 37) Unresolved reference: databinding Error:(22, 26) Unresolved reference: ActivityMainBinding Error:(38, 50) Unresolved reference: ActivityMainBinding Error:(43, 52) Unresolved reference: ActivityMainBinding Error:(46, 52) Unresolved reference: ActivityMainBinding Error:(49, 52) Unresolved reference: ActivityMainBinding Error:(52, 52) Unresolved reference: ActivityMainBinding Error:(55, 52) Unresolved reference: ActivityMainBinding Error:(58, 52) Unresolved reference: ActivityMainBinding Error:(61, 52) Unresolved reference: ActivityMainBinding Error:(64, 52) Unresolved reference: ActivityMainBinding Error:(67, 52) Unresolved reference: ActivityMainBinding Error:(70, 52) Unresolved reference: ActivityMainBinding Error:(73, 52) Unresolved reference: ActivityMainBinding Error:Execution failed for task ':app:compileDebugKotlin'. Comstacktion error. See log for more details 

El file build.gradle de nivel superior es el siguiente:

 buildscript { ext.kotlin_version = '1.1.3-2' repositories { google() jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.0.0-alpha6' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { google() jcenter() mavenCentral() } } task clean(type: Delete) { delete rootProject.buildDir } 

El file build.gradle del module es el siguiente:

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' apply plugin: 'kotlin-android-extensions' apply plugin: 'kotlin-kapt' android { compileSdkVersion 26 buildToolsVersion "26.0.1" defaultConfig { applicationId "com.example.jimil.calculator" minSdkVersion 15 targetSdkVersion 26 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } dataBinding{ enabled = true } } dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) androidTestImplementation ('com.android.support.test.espresso:espresso- core:3.0.1', { exclude group: 'com.android.support', module: 'support- annotations' }) implementation "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" implementation 'com.android.support:appcompat-v7:26.1.0' testImplementation 'junit:junit:4.12' implementation 'com.android.support.constraint:constraint-layout:1.0.2' kapt 'com.android.databinding:compiler:3.0.0-alpha6' } kapt { generateStubs = true } 

La class MainActivity.kt es:

 import com.example.jimil.calculator.databinding.ActivityMainBinding ... class MainActivity : AppCompatActivity() { private var binding: ActivityMainBinding? = null ... } 

Por favor, ayúdame a resolver el error de compilation.

Hay varios errores en tu gradle.

La versión actual de Gradle es 3.0.0-beta 3. Eso significa que debe cambiar su classpath para

 classpath 'com.android.tools.build:gradle:3.0.0-beta6' 

Lo mismo para sus dependencies

 kapt "com.android.databinding:compiler:3.0.0-beta6" 

También debe proporcionar sus complementos en la carpeta adecuada.

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' apply plugin: 'kotlin-kapt' apply plugin: 'kotlin-android-extensions' 

También debe habilitar las opciones de compilation para que sus procesadores de anotación utilicen dependencies de Java8 (que pueden ser necesarias para que Kotlin apunte a 1.8).

 compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } 

Una vez hecho esto, invalidate your cache and restart .

Si el error persiste, verifique la console de Gradle. Puede haber un error en su file XML que detiene su procesador de anotación para generar las classs de data binding.

  • Custom Jersey ExceptionMapper en Spring Boot con kotlin
  • Spring & kotlin: ¿Cuál es la diferencia entre el constructor y la inyección tardía?
  • ¿Qué es una forma concisa de copyr profundamente una MutableList 2D?
  • Kotlin REST a las definiciones de mecanografía
  • No se puede encontrar la vista en la hoja inferior con Espresso
  • Kotlin Capsule Gradle Error
  • ¿Cómo get el estado de entrega del post usando smack?
  • Cuál es el enfoque correcto cuando la function de Kotlin no toma el tipo de nullable
  • Kotlin Kmongo inserta y devuelve el elemento insertado
  • ¿Cómo puedo get el time que lleva una function probar el performance de las funciones en Kotlin?
  • Android Studio 1.5 con Kotlin Plugin recibió una exception, cuando está en modo debugging. ¿Como arreglarlo?